MAngband 1.5.0 alpha test

Think you've found a bug? Please report it here.
Post Reply
User avatar
Flambard
Giant Mottled Ant Lion
Posts: 219
Joined: Wed 20.06.2007, 10:49

MAngband 1.5.0 alpha test

Post by Flambard » Mon 11.02.2019, 07:22

Topic for all the bugs that are found during 1.5.0 alpha test.

Expect that a) you'll need to re-download the client often b) server savefiles will be destroyed frequently.

I'll also post updates when/if client re-download is necessary and/or the server is wiped.

How to play?

Make sure to backup your regular client install and the .prf files!

Windows

The semi-automatic builds are kept here: https://mangband.github.io/mangband-builds-win

Download buildRelease.zip and buildRelease-SDL.zip, and extract to some folder ("C:\MangbandAlphaTest"). When/if updates come, those zip files will be automatically updated, so you'll have to re-download them, from the same link.

macOS

Download the .dmg from here https://mangband.github.io/mangband-builds-osx and drag "MAngclient_dev" into "Applications" folder. When/if updates come, the .dmg file will be automatically updated, so you'll have to download the new one, from the same link.

Linux/BSD

For the time being, we expect you to compile from git, master branch.

How to report bugs?

We rely on your help to identify and squelch as many bugs as possible. If you see something, anything at all, that doesn't look right, please go ahead and tell us.

You can simply use this very thread, post issues at github and ofcourse, chat to us on Discord.

FAQ/Already reported bugs

Bumping into doors does not open them
Try tunneling into a door. To restore old behavior, set easy_alter=yes in Running/Inventory options (=3).

'g' doesn't pick up items
It now should. (Also, see here viewtopic.php?f=4&t=1897&p=8720)

Resting restores health uber-quick
Intended

Detect monsters flashes by too quickly
Set pause_after_detect=yes in Running/Inventory options (=3).

Reading scrolls always asks for item
That only happens for unidentified scrolls, so you can't opt-out of the negative curse/disenchant effect.

User avatar
tangar
Giant House Fly
Posts: 12
Joined: Sun 05.06.2016, 10:58
Contact:

Re: MAngband 1.5.0 alpha test

Post by tangar » Tue 12.02.2019, 08:55

yay :D cool! it would be also fun to see patchnotes ;)
youtube.com/GlazGame — streams in English ⍽⍽⍽⍽⍽⍽ youtube.com/StreamGuild — streams in Russian

User avatar
tangar
Giant House Fly
Posts: 12
Joined: Sun 05.06.2016, 10:58
Contact:

Re: MAngband 1.5.0 alpha test

Post by tangar » Tue 12.02.2019, 16:11

Ok, I've logged it :) But it's lagging.. (character jumping like rabbit). Ping is alright (pinging preview.angband.org), but lagometer in-game is yellow (50%).. so for now it's impossible to play

Noticed that there is an option auto_itemlist - good job!

Also a question - is tileset already works? How to turn it on?
youtube.com/GlazGame — streams in English ⍽⍽⍽⍽⍽⍽ youtube.com/StreamGuild — streams in Russian

User avatar
Flambard
Giant Mottled Ant Lion
Posts: 219
Joined: Wed 20.06.2007, 10:49

Re: MAngband 1.5.0 alpha test

Post by Flambard » Wed 13.02.2019, 06:44

Thanks for the feedback!
tangar wrote:
Tue 12.02.2019, 16:11
Ok, I've logged it :) But it's lagging.. (character jumping like rabbit). Ping is alright (pinging preview.angband.org), but lagometer in-game is yellow (50%).. so for now it's impossible to play
Uh-oh! Could you please tell me the following:
- do you have similar lag on main server/1.1.4 client?
- are you using Windows or SDL (One-Window) mode?
- if you're using Windows client, could you compare it to SDL (One-Window) client?
- and if you're using SDL client, could you compare it to Windows client?
tangar wrote:
Tue 12.02.2019, 16:11
Also a question - is tileset already works? How to turn it on?
For SDL client, edit mangclient.ini, find [SDL] section and change "Graphics" to 1, 2 or 3.
For Windows client, go to main menu, View -> Graphics, select appropriate tileset and restart the client.

User avatar
Flambard
Giant Mottled Ant Lion
Posts: 219
Joined: Wed 20.06.2007, 10:49

Re: MAngband 1.5.0 alpha test

Post by Flambard » Wed 13.02.2019, 08:31

Windows client updated. Re-download buildRelease.zip and use new mangclient.exe

User avatar
tangar
Giant House Fly
Posts: 12
Joined: Sun 05.06.2016, 10:58
Contact:

Re: MAngband 1.5.0 alpha test

Post by tangar » Wed 13.02.2019, 09:02

My story

Yesterday:

1) yestarday I've downloaded the 1.5.0 alpha setup package.
2) when you install it - it do not ask you where it would install the client
3) after Installation I've noticed that it;s installed the game to c:/games/MAngband (where I had my 'main' server installation)
4) I've tested new alpha server and had lags. I've tried both sdl and regular client

Today:
1) After I've read your message, I wanter to test lags at main server (1.1.4) // a few days ago I didn't had any lags there, but still good to test
2) I've donwloaded setup package from there https://mangband.org/downloads (as you can not login main server with 1.5 client)
3) I've installed setup (and it again didn't ask where to put the game) to c:/games/MAngband
4) now when I try to run the game I got an error:
Can not find required directory:
c:\mangband\lib
Please could you add 'zip' variants of the game for main server
youtube.com/GlazGame — streams in English ⍽⍽⍽⍽⍽⍽ youtube.com/StreamGuild — streams in Russian

User avatar
Flambard
Giant Mottled Ant Lion
Posts: 219
Joined: Wed 20.06.2007, 10:49

Re: MAngband 1.5.0 alpha test

Post by Flambard » Wed 13.02.2019, 12:16

after Installation I've noticed that it;s installed the game to c:/games/MAngband

UGH, terribly sorry about that! I'm guessing it has something to do with installer-app-GUID being the same for both versions :(

So, apparently you should not be using the installer! I'll update the first post ASAP.

To restore the 'main'/current/stable version, I think you can just
a) uninstall everything
b) delete the directory?
c) install from https://mangband.org/downloads

Then, keep 'main'/current/stable installed, and use Release*.zip for the alpha version.

[hr]

OK, I've updated the main post. Windows users should just extract the Release*.zip files somewhere, and forget about installer for the time being.

User avatar
tangar
Giant House Fly
Posts: 12
Joined: Sun 05.06.2016, 10:58
Contact:

Re: MAngband 1.5.0 alpha test

Post by tangar » Wed 13.02.2019, 12:54

Thanks.

1) tested: main server doesn't have any lags, everything smooth and nice
2) test server has 'rabbit' jumps-lags, not playable (maybe main server located in EU and test in US?)
3) also can not start SDL client, it gives an error that there is no SDL.dll

Note: but at TomeNET US server I don't have any lags
youtube.com/GlazGame — streams in English ⍽⍽⍽⍽⍽⍽ youtube.com/StreamGuild — streams in Russian

User avatar
Flambard
Giant Mottled Ant Lion
Posts: 219
Joined: Wed 20.06.2007, 10:49

Re: MAngband 1.5.0 alpha test

Post by Flambard » Wed 13.02.2019, 13:09

Thanks.

1) tested: main server doesn't have any lags, everything smooth and nice
2) test server has 'rabbit' jumps-lags, not playable (maybe main server located in EU and test in US?)
3) also can not start SDL client, it gives an error that there is no SDL.dll
1) 2) Alright, that would be our first serious issue... :( The servers are located on the same network, so that would be some kind of bug.. :(

3) Argh, thank you!

fixed, both .zip files now contain SDL.dll

TODO: only add SDL.dll to ReleaseSDL .zip file...

User avatar
Flambard
Giant Mottled Ant Lion
Posts: 219
Joined: Wed 20.06.2007, 10:49

Re: MAngband 1.5.0 alpha test

Post by Flambard » Wed 13.02.2019, 22:53

Clients updated. Re-download latest versions to continue.

..and fixed! There should be no more (gratuitous) lag nor any "rabbit-jumping"! Please give new version a try.

Post Reply